Die dedicated Server Software für den Landwirtschafts Simulator 2015 ist direkt in die Installation des Spiels integriert. Sobald das Spiel installiert ist, kann die Server-Software mittels dedicatedServer.exe im Spielordner gestartet werden.

LS 17 Dedicated Server
Unsere Anleitung für den LS 17 Dedicated Server ist da! In Form eines Video-Tutorials auf Youtube, siehe: https://games4linux.de/landwirtschafts-simulator-17-dedicated-server-unter-linux/

Diese Anleitung ist unter der Voraussetzung einer WINE-Installation auf dem Server geschrieben. Sie richtet sich an fortgeschrittene Linux Server Administratoren, oder solche, die es werden wollen. Alle Bash-Angaben oder Beispiele sind für Debian 7 optimiert, aber sie funktionieren mit entsprechenden Anpassungen auch auf allen anderen Linux-Distributionen. Die Ausnahme: Debian 6 wird nicht unterstützt, da Debian 6 (oldstable) kein Multiarch versteht.

[quote_right]Nutze keine Steam Version[/quote_right]Steam-Versionen des Spiels werden als dedicated-Server NICHT unterstützt. Du musst dein Spiel auf http://farming-simulator.com gekauft & heruntergeladen haben. Die Installationsdatei heisst zum Beispiel: FarmingSimulator2015DE_withPatch1.1.exe

Achtung: Du benötigst für den Server eine eigene Spiel-Lizenz zum Vollpreis! Falls du für deinen Server keine separate Serial kaufst, wirst du selbst nicht darauf spielen können. Leider war das schon bei LS2013 so, aber immerhin muss man bei Farming Simulator 15 nicht auch noch – zusätzlich zur zusätzlichen Spiele-Serial – nochmals 10 Euro für die Server-Software ausgeben. Immerhin, immerhin….

Die Voraussetzungen für deinen dedicated Server @Linux

Das Admin-GUI für deinen dedicated LS 15 Server ist ganz praktisch und funktioniert genauso gut wie unter Windows.
Das Admin-GUI für deinen dedicated LS 15 Server ist ganz praktisch und funktioniert genauso gut wie unter Windows.

Dein Server sollte in jedem Fall genügend Rechenleistung und RAM verbaut haben. Die Mindestvoraussetzungen sind ungefähr gleich wie unter Windows, steigen aber bei bis zu 16 Spielern (Max) an.

  • 2.6 GHz oder mehr
  • 2 GB RAM oder mehr
  • 4GB Festplattenspeicher oder mehr

Dein Linux-Server braucht nebst installierten WINE (stable) für den Start & Betrieb des Gameservers auch ein funktinionierendes X-Forwarding für die einmalige Installation. Sofern du an Windows mit Putty auf deinen Linux-Server zugreifst, brauchst du demzufolge auch ein Programm (z.B. XMing) um das X-Forwarding unter Windows anzuzeigen. Einfacher geht es mit Linux: Mit Ubuntu als Gamer-PC beispielsweise kann das X-Forwarding mit -X während dem SSH-Connect für die Session aktiviert werden, XMing oder ähnliche Programme sind nicht nötig.

Folgendes musst du jetzt vorgängig installieren, erst danach bist du und dein Server bereit für die Installation & Starten des Landwirtschaft Simulators 2015 dedicated Servers.

Ob dein X-Forwarding funktioniert, kannst du mit der „xterm“ testen. Installiere xterm und rufe es auf; wenn ein neues Fensterchen ähnlich deiner Bash sich öffnet, dann funktioniert dein X-Fowarding und du bist bereit für die echte LS 15 dedicated Server Installation:

su - root
apt-get install xterm
logout
xterm

Die Installation

  • Uploade FarmingSimulator2015DE_withPatch1.1.exe
  • Erstelle einen User, mit dem dein Server läuft. Wechsle auf diesen User.
    • Optional: Teste nochmal dein X-Forwarding, gib ein: xterm
adduser ls2015-server
su - ls2015-server
  • Installiere das Spiel mit wine
wine FarmingSimulator2015DE_withPatch1.1.exe
  • Starte das Spiel FarmingSimulator2015.exe, damit du deinen Spiele-Key eingeben kannst
wine .wine/drive_c/Program\ Files/Landwirtschafts\ Simulator\ 2015/FarmingSimulator2015.exe
  • Es erscheint die Meldung: „Spiel Key erfolgreich registriert“ (o.ä.), brich ab mitSTRG+C
    • Optional: Öffne die dediatedServer.xml und setze dir ein Admin-Passwort, oder ändere den Port (Default: 8080)
  • Starte den dedicated Server dedicatedServer.exe
wine .wine/drive_c/Program\ Files/Landwirtschafts\ Simulator\ 2015/dedicatedServer.exe
  • Öffne das Web-GUI zur Administration deines Server. Der Port steht in der dedicatedServer.xml (Default: 8080)
    • http:// deine IP:8080
  • Logge dich ein mit „admin“ und deinem Passwort (steht in dedicatedServer.xml)
  • Starte den Server mit dem Button „Start“ (das Web-GUI ist selbsterklärend)

Fertig!

Wie ist die Performance CPU/RAM?

Der Performance-Verlust mit WINE ist tatsächlich minimal, oder anders ausgedrückt: Die Performance ist super! Maximale 16 Spieler übersteigen keine 100% von nur 1 Core im Early-Game. Das ist nicht so gut wie ein Counterstrike-Server, aber immerhin ist es erträglich zu handhaben.

Die RAM werden mit 2GB angegeben, i.d.R. übersteigt der Server diese Angabe nicht. Sollte ein Memory-Leak die Runde machen, kann im Web-GUI sogar ein Auto-Restart konfiguriert werden. Typisch Windows 😉

Update vom 31.10.2014: Mit WINE 1.7.21 ruckelt der Server eher störend, jedoch mit WINE 1.7.30 ist das Ruckeln so gut wie weg. Es fühlt sich an wie eine Latenz von 200ms was OK ist.

Server im Hintergrund laufen lassen?

Ich benutze tmux, d.h. ich brauche kein screen. Tmux empfehle ich sowieso allen fortgeschrittenen Linux-Server Administratoren, oder solche, die es werden wollen. Mit Screen geht es aber auch.

apt-get install screen

Anwendungsbeispiele für screen & ls2015 benötigt? Alle Fragen dazu bitte in die Kommentare.

Ansonsten habe ich ein tmux Learing-Video auf Youtube veröffentlicht (unten).
Eine ausführliche, und hoffentlich gut verständliche Text-Form ist hier: Games4Linux.de: Game-Server im Hintergrund laufe lassen

TEILEN
elysium

Elysium spielt seit 2012 unter Linux, aktuell mit Linux Mint 18. Beruflich bin ich im Bereich Middleware auf Linux-Server unterwegs. Für diverse Adobe Applikationen bleibt mein Dualboot Linux/Windows bestehen. Und in seltenen Fällen für DirectX only Games..

83 KOMMENTARE

  1. Ich verstehe diesen Hype um das Spiel überhaupt nicht. Aber warum man für den Server eine eigene Lizenz benötigt verstehe ich noch viel, viel weniger …
    Immerhin – schönes Tutorial 🙂

    • Problem war englischer Steamclient, der stellt das spiet bei jedem Start wieder auf englisch zurück.
      Funktioniert alles sauber und läuft stabil. Gute Anleitung! Danke!

  2. @momo, Ja, definitiv.
    Ich musste zwar meinen NVidia Treiber updaten (okay, der war wirklich etwas älter), dann hat es geklappt. Die Performance ist absolut OK und gut spielbar.
    Mit dem alten Nvidia Treiber konnten die Intro-Videos nicht angezeigt werden wodurch alles hängen blieb. Ich benutze jedoch ein selbst kompiliertes wine 1.7.30, ob es mit 1.6.2 (stable/älter) auch so gut funktioniert, kann ich dir morgen sagen.

  3. Moin zusammen,

    da hier ja doch die geballte Linuxpower ist, vielleicht habt ihr einen Tipp. Ich habe das ganze auf meinem Dedi-Server installiert. Wine weist dem Spiel aber immer wieder http://127.12.34.56:xxxx als IP zu und ich komme so nicht auf den Server. Das Webinterface ist zu erreichen aber beim Spiel selber bekomme ich eine Fehlermeldung „Es konnte keine Verbindung zum Multipayer-Spiel hergestellt werden“.
    Habt ihr vielleicht einen Tipp? Die Google Suche habe ich schon gemacht.. hab aber kein Bock die /etc/hosts umzuschreiben da dann mein Server ja ggf. komplett nicht mehr erreichbar ist.

      • Hi, habe auch das Problem mit der IP.
        Wenn ich den dedicatedserver starte, spuckt er mir die 127.12.34.56 aus.
        Mit hostname -i bekomme ich jedoch meine richtige externe IP angezeigt und auch unter /etc/hosts ist diese richtig eingetragen.
        Nun komme ich nicht weiter.

        • Da ich nicht betroffen bin, müssten wir von Beginn an troubleshooten. Sofern hostname -i nach wie vor keine 127er IP ausgibt, stellen sich folgende Fragen:

          Welche Distribution? Welche Version von wine wurde installiert? Falls sie kompiliert ist, was sind die letzten 15 Zeilen von ./configure ? (Dort werden nicht konfigurierte Module erwähnt, bei allenfalls fehlenden Libraries) Funktioniert es mit WINE 1.7.31 auch nicht? (Neuster Developer-Branch, auch hier sollten keine fehlenden Libs nach ./configure erwähnt werden)

          • Hi, kleines update meinerseits.

            habe Stundenlang Google und die Bugmeldungen auf Wine durchforstet. Jedoch ohne eine wirkliche Lösung. auch die manuelle Konfiguration des Netzwerkadapter per wine und windows konsole führte nicht zum Erfolg. Vielleicht lief beim Dist-Update von Debian 6 auf 7 was schief.

            Hatte mich nun dazu durch gerungen meinen Server mit Ubuntu neu aufzusetzen.
            Läuft jetzt mit Ubuntu 12.04 und wine habe ich mit PPA über apt-get installiert. Also Version 1.6.1.
            Ansonsten bin ich gemäß deiner Anleitung verfahren.
            Er gibt mir zwar immer noch die falsche 127 IP in Wine aus, der Dedi ist jedoch über die richtige Server IP erreichbar und läuft ohne Probleme.
            Spielen mit bis zu 8 Leuten auf dem Server, ab und zu gibt es minimale Lags ist aber zu Verschmerzen. auch die Systemauslastung liegt unter den Mindestanforderungen.
            Maximal 80% von 1 core ausgelastet und höchstens 1 GB RAM.

            Das Ganze läuft auf einem V-Server, bin daher doch postiv überrascht.

  4. Hallo elysium,

    da steht die IP meines Servers drin :). Das passt also wirklich.
    Komischerweise kann ich auch das Webinterface erreichen. Es klappt nur nicht mit dem Verbinden auf dem Server. Ich probiere es heute Abend noch mal weiter. Ich habe gestern Abend noch, eher aus Verzweiflung, KDE installiert damit ich mal linuxtoplay? installieren kann. Da machte mir dann aber irgendwann das Bett einen Strich durch die Rechnung… :). Zum Glück ist das wirklich nur mein Spieleserver.

  5. Ausgezeichnetes Spiel, fing ich an, es zu spielen und ich bin beeindruckt. Gutes Forum für dieses Spiel hier [ Link entfernt. Sinnlose Backlinkgrinder sind hier nicht erwünscht. elysium ]

  6. Hallo alle zusammen
    Tolles spiel und gutes Tutorial!

    Ich hab da mal ne Frage:
    Bezieht sich das mit keine Steam-Lizenz verwenden nur auf das Server erstellen oder kann ich dann auch mit keiner Steam-Lizenz des Spiels auf dem server beitreten?

    Viele Grüße Hessi

    • Hallo Hessi

      Leider ist es so, bevor der Server im Web-GUI mit dem Button „Start“ endgültig hochgefahren werden darf, muss zwingend 1x die FarmingSimulator.exe hochgefahren werden – und diese verlangt eine gültige Spiellizenz. Klar, du kannst dort deine eigene Serial eingeben, die du fürs spielen gekauft hast. Aber dann kannst du selbst nicht mehr im Multiplayer spielen, denn sobald du in den Multiplayer wechseln willst erscheint eine Fehlermeldung „Serial already in use“ o.ä.

      So werden Server-Betreiber gezwungen, das Spiel 2x zu kaufen. Wenn du mich fragst – schrecklich! & pure Abzocke.

  7. Hi Aber wie bekomme ich denn diese instalations datei ich habe ja die beiden sachen auf cd aber
    Finde nirgens die datei zum downloaden bidde helft mir
    Danke

  8. Servus
    gibt es schon eine Problemlösung bezüglich dem oben genannten Problem mit der Server Erreichbarkeit?
    Ich habe das selbe Problem, das Webinterface erreiche ich ohne Problem während der Server im Spiel nicht angezeigt wird.

    Gruß Moritz

  9. Hi Leute, cooles Tutorial. Werde es bei Gelegenheit mal testen. Eine Frage habe ich aber. Brauche ich für das Game auf dem Server eine grafische Oberfläche wie Gnome oder kann ich es komplett über die Kommandozeile nutzen?

    Gruß RlDDlCK

  10. Du bräuchtest eine Grafische Oberfläche um das Spiel per Wine zu installieren, darum wird hier auch erklärt wie der X-Forward eingerichtet wird, so kannst du das auf einem Server ohne Desktop machen und bekommst die Fenster auf deinen Rechner weitergeleitet.

    btw.. super Sache das Tut, ich war schon kurz davor eine VM auf meiner Linuxkiste aufzusetzen, Wine hatte ich ganz vergessen 🙂

  11. Hey Leute,
    bei mir funktioniert soweit alles super, so mit Server starten und einrichten,
    ABER da mein LS15 derzeit auf 1.2 geupdatet ist finde ich InGame meinen Server nicht.
    Mir wurde zugetragen, dass es an den Versionsunterschieden liegt, da der Server auf 1.1 läuft!
    Nun bekomme ich es aber nicht hin den Server zu updaten,
    hat einer von euch eine Ahnung, wie dies gehen könnte??

    Eine schnelle Antwort wäre mir sehr lieb 🙂
    MfG Boettchie

    • Das geht genau so , wie du Version 1.1 installiert hat. Anstatt wine FarmingSimulator2015DE_withPatch1.1.exe ausführen musst du den Patch .exe Herunterladen, auf dem Server hochladen und mit „wine xyz.exe“ ausführen.

      • Dies habe ich getan!
        Muss ich dafür die alte .exe löschen oder noch andere Schritte befolgen?

        Nachdem ich die Patch.exe ausgeführt habe, habe ich einmal die dediserver.exe ausgeführt
        und bin in mein Webinterface gegangen, dort habe ich versucht den Server zu starten,
        aber danach kommt die Fehlermeldung 🙁
        Was mich auch verwundert hat ist, dass die Versions Nr. in der VERSIONS Datei auf 1.2.0.0 geändert hat aber im Webinterface steht immer noch 1.1.0.1 oder so …

        Könntest du evtl. Heute oder Morgen mal auf unseren TS kommen,
        wäre voll Nice!? ts3.mineto-gaming.de

  12. und wie funktioniert das ganze jetzt auf 1linux-server? ich meine dort hat man keine grafikausgabe sondern nur das terminal und die verzeichnisse sind auch anders da braucht man aber schon extreme linux kentnisse um das auf seine linux variante anzupassen

  13. Hallo habe soweit alles hinbekommen. Nun möchte ich jedoch mit # wine FarmingSimulator2015DE_withPatch1.1.exe

    das Game installieren, jedoch bekomme ich folgende fehlermeldung

    wine: Fehlerhaftes EXE-Format für Z:\home\USER\FarmingSimulator2015DE_withPatch1.1.exe.

    Ich nutze ein 64bit LinuxSystem.

  14. Hallo, ich habe mir heute den Patch installieren wollen angefangen haben ich mit

    wine FarmingSimulator2015Patch1.3DE_PublicBeta1.exe

    Die installation des Patches erfolgte ohne probleme. Aber als ich dann das Spiel starten wollte mit

    wine home/Mario/.wine/drive_c/Program\ Files/Landwirtschafts\ Simulator\ 2015/FarmingSimulator2015.exe

    kommt ganz kurz das xming fenster (blitzt kurz auf) und dann passiert nichts weiter.
    http://www.der-ls-treffpunkt.de/images/xming.jpg

    Kann mir da wer weiter helfen?

    • Du versuchst das Spiel zu starten, nicht den Server, richtig? Die Fehlermeldung deutet auf neuere Garfikfeatures hin, welche WINE nicht unterstützt (mit dem Patch mitgekommen?). Welche exakte WINE Version hast du?

  15. Hallo zusammen,

    Ich wollte auf das oben aufgetretene Problem noch mal zurück kommen:

    „Es konnte keine Verbindung zum Multipayer-Spiel hergestellt werden“

    Gibt es hier zu eine Lösung?

    – wine Version 1.6.2
    – hostname -i entspricht der richtigen IP
    – Firewall deaktiv
    – Webinterface über IP:port erreichbar
    – Gameserver fährt hoch ohne Fehler
    – Spielversion 1.3 LS2015
    – Debian 7.8

    Der Server wird im Spiel gefunden aber wenn man Connecten will kommt die o.a. Fehlermeldung

    • So nach langem hin und her hab ich die Lösung gefunden:

      Im Webinterface den Port von 10823 geändert auf 10830 und server gestartet. Danach kann man joinen.

    • Hi R3vlis,

      bei welchem Schritt bleibt es hängen? Ich habe derzeit sehr wenig Zeit, könnte aber u.U. doch kurz helfen. Anhand einer Info könnte ich mich schon vorher kurz darauf vorbereiten.

      • Hallo,

        Ich kann paar pakete nicht installieren. Ich habe mal xrdp installiert um für die installation die grafische oberfläche zu haben. Leider komme über diese nicht mehr drauf. Am liebsten wäre es mir wenn da einer mal komplett drüber schaut und mir bisschen erklärt.

        Lg

  16. Läuft die Version 1.4.1 bei dir immer noch mit nur wenigen Prozent auf einem Core wenn ihr mit so viel spielt ?
    Und was hast du für einen VPS ?
    Ich habe einen VPS mit 30GB Ram und 6 Kernen zur Verfügung und wenn ich den LS15 Dedi starte und ein spieler joint, dann rennt ein Core direkt auf 80-90% hoch, nehme ich eine anderen Wine Version als die 1.6.2 dann heißt es Laggs des Todes und 1 Core auf 100%, da ist es Solo schon unspielbar.

    • Wäre halt interessant mehr über dein System zu erfahren, wo hast du das wine 1.6.2 her, noch was anderes installiert oder oder oder 🙂

  17. Moin,
    habe alles so gemacht wie beschrieben. Habe Wine 1.6.x Wenn ich den Server aber über Screen -S fs15 dedicatedServer.exe starte und den Server im Web Panel starte geht der Button beim Reiterwechsel wieder off.

  18. Moin,
    habe alles so gemacht wie beschrieben. Habe Wine 1.6.x Wenn ich den Server aber über Screen -S fs15 wine dedicatedServer.exe starte und den Server im Web Panel starte geht der Button beim Reiterwechsel wieder off.

    • Ich würde es mit einer neueren Wine Version ausprobieren, 1.7.x, oder sogar 1.8(-rc4) dioe basiert auf der neusten 1.7.x und wird auch als stabile version die bisherige 1.6.2 stable ablösen 🙂

  19. Hallo,

    ich bräuchte mal Hilfe bei der Installation. Bin soweit alles durch, hab wine 1.6.2 installiert nur wenn ich jetzt das Spiel installieren möchte bekomme ich folgenden Fehler:

    „Application tried to create a window, but no driver could be loaded.
    Make sure that your X server is running and that $DISPLAY is set correctly.“

    Kann mir da jemand helfen? Am besten mit TS.
    Gruß Azuma

    • Hallo Azuma,

      dein X-Forwarding funktioniert nicht. Du kannst wie in der Anleitung beschreiben das Programm „xterm“ öffnen um zu testen, ob X-Forwarding funktioniert. X-Forwarding öffnet das Programm sozusagen auf deinem PC während du es auf dem Server startest. Das braucht es für die grafische Installation von LWS15.

      Ggf. lohnt es sich inzwischen WINE 1.8 zu benutzen, das ist der stabile Nachfolger von 1.6.x (löst aber das X Forwarding Problem nicht 🙂 )

  20. Hallo, ich hoffe mir kann jemand helfen.
    Ich habe das Spiel installieren können. Den Server bekomme ich auch gestartet.
    Allerdings bekomme ich einen Fehler, wenn ich im Webinterface auf „starten“ klicke.
    Mir wurde gesagt, das der Server ohne eine „richtige“ Grafikkarte wohl nicht laufen würde.
    Das kann ich aber fast nicht glauben?!

    Ich habe einen Debian8 Server mit wine 1.9.7

    Ports habe ich in der Firewall freigegeben:
    beispiel:
    $IPTABLES -A INPUT -p tcp –dport 10830 -j ACCEPT

    in der Konsole starte ich das Spiel mit:
    /usr/bin/wine64 /home/ls2015/.wine/drive_c/Program\ Files\ \(x86\)/Landwirtschafts\ Simulator\ 2015/dedicatedServer.exe

    Als Ausgabe erscheint:

    fixme:winediag:start_process Wine Staging 1.9.7 is a testing version containing experimental patches.
    fixme:winediag:start_process Please mention your exact version when filing bug reports on winehq.org.
    fixme:heap:RtlSetHeapInformation (nil) 1 (nil) 0 stub
    GIANTS Dedicated Server/6.0.8.1
    fixme:ntdll:__syscall_NtLockFile I/O completion on lock not implemented yet
    Config file: C:/Program Files (x86)/Landwirtschafts Simulator 2015/dedicatedServer.xml

    URL: http://XXX.XXX.XXX.XXX:XXXX
    Please refer to config file for initial admin password.

    Press ‚CTRL-C‘ to stop the server…

    Besagter klick auf „Start“ im Webinterface führt dann zu einem:

    Mod directory: C:/users/ls2015/Meine Dokumente/My Games/FarmingSimulator2015/mods/
    Started network game (10830)
    Error: Failed to connect
    Error: Es konnte keine Verbindung zum Server hergestellt werden.

    In der Konsole kommen noch ein paar Infos von wine selber:

    fixme:heap:RtlSetHeapInformation 0x240000 0 0x23fd10 4 stub
    fixme:heap:RtlSetHeapInformation 0x350000 0 0x23fe10 4 stub
    Render System
    Driver: NULL
    NullConsoleDevice initialized
    Hardware Profile
    Level: Low (forced)
    View Distance Factor: 0.750000
    Shadow Quality: 0.000000
    Skip Mipmaps: 1
    LOD Distance Factor: 0.750000
    Terrain LOD Distance Factor: 0.750000
    Foliage View Distance Factor: 1.000000
    Volume Mesh Tessellation Factor: 1.500000
    Tyre Tracks Segments Factor: 0.500000
    fixme:ntdll:NtQuerySystemInformation info_class SYSTEM_PERFORMANCE_INFORMATION

    oder

    fixme:ntdll:NtQuerySystemInformation (0x0000007f,0x23edd0,0x00000280,0x23bf00) stub
    fixme:advapi:GetCurrentHwProfileA (0x23bf88) semi-stub
    fixme:process:GetSystemRegistryQuota (0x23c008, 0x23c00c) faking reported quota values
    fixme:ntdll:NtQuerySystemInformation info_class SYSTEM_INTERRUPT_INFORMATION

    Kann mir da jemand weiterhelfen?

    Die Fehlermeldung das keine Verbindung hergestellt werden konnte irritiert mich auch etwas.
    Kann er lokal keine Verbindung aufbauen, oder versucht er sich beim Masterserver ohne Erfolg zu
    verbinden? Oder bin ich da ganz falsch?

    Grüße

    Spion

        • Ich komme nur soweit,das ich den key eingeben und dann wars das… es erstellt sich nur ein ordner etc. kannst du mir helfen?

        • Felix hat mir per eMail geschildert, er benutzt die Amazon Download-Version, nicht wie in der Anleitung beschrieben von farming-simulatar.com… Ein wichtiges Detail 😉
          Ich habe ihm die aktuelle FarmingSimulator2015DE_withPatch1.1.exe von farming-simulator.com hochgeladen und er probiert jetzt damit mit seiner Amazon-Serial.

          Parallel habe ich meine Anleitung nochmal selbst ausprobiert, auf dem Debian 8 Server (nicht mehr 7): Funktioniert wie beschrieben einwandfrei. Auf diesem Debian 8 habe noch ein altes wine-1.6.2 installiert und für meine Testinstallation benutzt, ich empfehle aber immer die aktuellste Stable Version (derzeit 1.8.2) oder wenn das nicht ausreicht die neuste Developer-Version (derzeit 1.9.10) >> http://winehq.org

          • Hey,
            Die Installation hat geklappt,doch nun bekomme ich es nicht upgedatet auf den neusten Patch… Kannst du oder jemand anderes mir helfen?

          • Der neuste Patch wird – wenn man die Version von http://www.farming-simulator.com hat, nach dem Spielstart zum Download angeboten (es öffnet sich ein Browser mit Download-Link). Die derzeit aktuelle Datei ist von 16. Januar 2016 und heißt FarmingSimulator2015Patch1.4.2DE.exe

            Ich lade sie dir hoch, dauert aber einen Moment (336MB). Danach diesen Patch mit „wine FarmingSimulator2015Patch1.4.2DE.exe“ auf dem Server gleich wie vorhin das Spiel ausführen und so erneut mit X-Forwarding installieren.

            Nach diesem Patching ist die dedicatedServer.exe im Verzeichnis wo das Spiel installiert ist automatisch aktualisiert (in /home/DEINUSER/.wine/drive_c/Program\ Files/Landwirtschafts\ Simulator\ 2015/dedicatedServer.exe). Einfach mit „wine dedicatedServer.exe“ ausführen, es kommt dann die Meldung dass die Version jetzt 6.0.8.1 ist (vorhin ohne Patch: 6.0.2.0.).

            Ich hab’s gerade getestet, der Server taucht nach dem Patch in der Serverliste korrekt auf.

  21. Hallo,
    ich habe nun das ganze unter Ubuntu installiert.
    XForwarding läuft
    Der Server startet auch wird aber nur lokal für mich im Netzwerk angezeigt.
    Wie bekomme ich es hin das er nach draussen kommuniziert das meine anderen Mitspieler übers Internet joinen können?!

    DAnke schonmal im voraus

  22. Home Server?

    Dann müsste man sehr warscheinlich Ports freigeben sowie deine öffentliche IP in der Config eintragen und nicht 192…… Also die Interne. Wenn du magst kann ich dir ggf dabei helfen. Antworte dann mal auf den Kommentar hier 🙂
    Mfg
    Felix

  23. Hi Felix
    Ja das wäre cool?

    Ich muss erstmal schauen ob ich noch eine dömane bei meinem DNS Anbieter frei hab

    Hab eben den Server neu gestartet mir aber net behalten wie das Passwort vom Server lautet und wenn ich such find ich die dedicatedserver.xml net mehr ?

    Ich werde sicherlich kein Linux Freund ?

    Ich hätte einen ts3 Server oder wie könnten wir das machen?

  24. Linux ist eigentlich nicht besonders Schwer (Wenn man einmal drin ist :D)
    Ich hätte auch ein TS 3 etc. Ich hätte jetzt spontan gesagt melde Dich mal bei uns im Support,Problem ist nur das ich gerade unsere Webseite auf Links drehe und ein Ticket System noch einbaue etc. Nur unser Live Support wäre verfügbar. Ich weis ja nicht wann Du so on bist etc. vlt möchtest Du das hier schreiben oder aber per Mail (felix@pg-mg.de),unseren Live Support kannst Du auch gerne nutzen um mir/uns das mitzuteilen(schnellster Weg) Dann können Wir uns gerne mal auf einem TS treffen. Wir helfen auch anderen Leuten bei Servern/Software,doch leider ist ja wie schon erwähnt der zeit unsere Webseite nicht komplett on,daher kann ich Dir unsere Hilfe Seite nicht senden per Link. Trotzdem kannst Du Dir diesen Link pg-mg.de schon mal merken. Mfg Felix

  25. Hi Fabai
    Ich bins nochmal…
    Ich hatte dir schon ne Mail gesendet das es sich bei mir verspäten könnte,da ich noch weg musste. Sollte es heute nicht mehr gehen, wann bist du morgen Online ? Und sorry das ich dir heut Vlt nicht helfen kann bzw. Erst später

  26. Hallo hab mal ne Frage es geht um den Farming Simulator 2017

    Ich hab es probieren nach der Anleitung zu machen nur mit der 2017 Version leider ging es nicht kann da Wehr weiter helfen

    • Moin,
      ich habe es seit 2 Tagen erfolgreich geschafft,meinen Server und den Server von 2 weiteren Personen online zu bringen. Darf ich einmal Dein OS erfahren? Sonst kannst du auch jederzeit eine Mail mit Deinem Problem an support@pg-mg.de oder an felix@pg-mg.de senden. Ich werde Dir mit Sicherheit weiterhelfen können 🙂

      Mfg
      Felix

    • Staus Update:
      Ironkiller ist zur Zeit bei mir aufem TS,es liegt an seinem Server das es nicht richtig funktioniert mit dem LS 17 Dedi, die Linux Versionen die er installieren kann haben alle einen Fehler wenn es um apt-get update geht. Nun setzt er auf den Support seines Hosters,damit das Problem behoben wird.

  27. Hi
    Ich oder pg-mg können dir da sicher helfen
    Kannst ja mal auf dem ts ts Server 109.230.254.7 kommen oder bei pc-mg.de ein Supportticket erstellen

  28. Also ich habs heute soweit auf ubuntu installiert. Leider kann ich disen aber nicht richtig starten. Bekomme die ganze zeit systemtime stub oder sowas.

    Jedenfalls klappt die installation + aktivierung.

    • @Felix habt ihr auch eine Lösung mit dem 127.0.0.1 Problem, dass der LS17 keine Public-IP mehr anzieht beim hochfahren? Man kann ja per Default das Admin Panel nur mit einem X-forwarded Firefox/Iceweacel öffnen.

      Ich konnte den Zugriff auf 127.0.0.1:8080 via Apache Reverse Proxy möglich machen, so dass das Admin Panel gewohnt über ein Browser zu öffnen ist. Das ist aber für unerfahrene eher unzumutbar. Und die App funktioniert damit auch nicht.

  29. Ja,zur Zeit noch leicht aufwändig… und zwar muss man als Root seine Interne IP einmal down schalten. Bei den meisten ist es ifconfig lo down dann den ls 17 starten und dann wieder als Root ifconfig lo up. Dann hat der Server die öffentliche IP. Das ganze klappt unter Ubuntu als auch Debian. Den LS 17 Natürlich nicht als Root ausführen,was ja eigentlich jedem klar sein sollte. Das ganze wird mit Wine 1.9.21 ausgeführt,und bei einem 64 Bit System schreibt man wine64 .wine/PFAD ZUR DEDICATED.EXE Dann klappt alles reibungslos 🙂

  30. Felix bei mir kommt immer die Meldung
    Warning: Map image file ‚data/maps/map01/pda_map_H.png‘ not found.
    Hast du dafür auch ne Lösung

  31. Moin Tut optimal, leider ein kleines Problem mit LS2017 dedi , startet scheint auch zu laufen leider wird aber die Webseite nicht angezeigt zum Starten und sonstiges habe ich da was übersehen? der LS2015 rennt nur der 2017 mag mich nicht :/

    Wenn mir da mal jemand nen Trick verrät wäre das gut, ja Port 8080 beim 2015 und beim 2017 8081 etc. selbst ohne laufenden 2015 über 8080 nicht sichtbar

  32. Abend….
    Erstmal Danke das Ihr mich so zahlreich angeschrieben habt…
    In den letzten 2 Tagen habe ich weiteren Leuten erfolgreich geholfen ihren LS 17 Dedi Server online zu bringen.
    Mich haben bis jetzt 22 Personen angeschrieben. Wovon die Hälfte recht schnell erledigt war da es „nur“ an kleineren Sachen haperte. Bei den anderen ist es schön etwas mehr gewesen,zwei sind jetzt noch offen…
    Daher würde ich nun alle bitten,die mich jetzt noch kontaktieren möchten,ein kleines Ticket zu erstellen,damit die Verwaltung der einzelnen Personen einfacher ist,so sind auch die gesendeten Nachrichten einfacher bzw. besser zusammengefasst als wenn man sich Mails hin und her sendet. Hier ist der Link zum Ticket System(bitte in die Abteilung/Hilfethema „Benötige Hilfe“ stellen. Dort dann einfach das Formular ausfüllen. Der Link: https://pg-mg.de/ticket-support/ (hoffe darf diesen hier Posten)

    Mfg
    Felix

  33. hallo und guten tag

    leiter bekomem ich ls17 mit der anleitung nicht installiert folgende meldung bekomme ich angezeigt -bash: wine: Kommando nicht gefunden. wine ist installiert ist ein linus debianserver

HINTERLASSE EINE ANTWORT